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MX DESIGNER

Designer is the software design program for the Home Theater Master MX-1000 universal learning
remote control. It is simple and interesting to use. The “drag ‘'n’ drop” is a key concept of the
program, allowing you to easily position buttons on device Pages. Drawing tools are provided to
help you create your own buttons.

This Quick Start Guide is provided to allow you to get right into using the Designer software. For
more detail, refer to the MX Designer User Guide.

Quick Start outlines the following:
¢ Navigation tips

o File transfers

Upload program files from the MX-1000 remote to the software

Download program files from the software to the MX-1000 remote

Change and replace buttons
Edit buttons and text

Import command sets from earlier versions of MXOP

NAVIGATION TIPS

HTM Designer features an interesting navigation capability among its many other benefits. We call it
the “Double-click 'n” Go” trick. It applies both to the Main Device Page screen, and to individual
device Pages.

1. Open the Main Device page. Double-click on any Device button to jump to the first page
of the Device.

2.  Open any Device page. Double-click the Last Page icon to cycle through the Pages in that
Device.

PREPARING THE SOFTWARE

To install the software, double-click on the mx-1000.exe file and follow the instructions. Once
installed, connect your MX-1000 remote, using the provided cable, to a free serial port on your PC.
Serial 1 seems to work best, with the bit rate of the port set to 115,200.

Run the software from the Start > Programs menu to load the default .mx operating program.
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FILE TRANSFERS

SAVE YOUR PROGRAM FILES FIRST

Before beginning the process, you should always save the programming you have already performed
on the MX-1000. You can then easily retrieve the settings if you need them. This section describes
how to do just that.

UrPLoAD PROGRAM FILES FROM THE MX-1000 REMOTE

On the remote, go to System Settings > Program Loading to prepare.

2. With the MX-1000 serial cable plugged in, click the Upload button on the software
Buttonbar.

3. Inthe software, select Save as new file for the operating program.

On the remote screen, press the UpLoad button under the heading Operating Program.
The software shows a progress bar, and displays an “Upload program completed” message
when done.

5. Click OK, and type in a filename in the Save As dialog box.

UPLOAD LEARNED FUNCTIONS FROM THE MX-1000 REMOTE

On the remote, go to System Settings > Program Loading to prepare.

2. With the MX-1000 serial cable plugged in, click the Upload button on the software
Buttonbar.

3. In the software, select Update the learned functions to current file.

On the remote screen, press the UpLoad button under the heading Learned Program. The
software shows a progress bar, and displays an “Upload program completed” message
when done.

5. Click OK to proceed with other work; the file is saved automatically to the *.mx file you
have open. Alternately, you could select the Save as new file for the operating program
option and upload the program files.

6. Select Save as new file for the operating system, and type in a filename in the Save As
dialog box.

DowNLOAD PROGRAM FILES AND LEARNED FUNCTIONS TO THE MX-1000 REMOTE

On the remote, go to System Settings > Program Loading to prepare.

2. With the MX-1000 serial cable plugged in, click the Download button on the software
Buttonbar.

3. Press the DownLoad button on the remote screen. The software asks if you would like to:

¢ Download Program Data, or
¢ Download Learned Data.
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4. Press the DownLoad button under the heading Operating Program on the remote. The
software shows a progress bar, and displays a “Completed downloading of operating
program data” message when done.

5. Inthe same dialog box, you are then given the opportunity to download Learned Data. To
download Learned Data, follow the same steps but press DownLoad under Learned
Program on the MX-1000.

THE WORKSPACE

Designer refers to the operating program files as the Workspace. You do all your button edlits,
drawing, and program manipulating within a Workspace that you then save with an extension of . mx.

To open a Workspace: Click File > Open Workspace, and select your * . mx file.

To close a Workspace: Click File > Close Workspace. If you have made changes to the file, a Save
dialog box opens. The Close Workspace function clears the program of your current work without
closing Designer.

To save a Workspace: Click File > Save Workspace or Save As Workspace when you have a file
open in Designer.

MX DESIGNER INTERFACE

MENU BAR

Designer's Menu bar is pretty straightforward, but there are a couple of items of
special interest:

¢ New Button: Opens a blank button Draw window

Load Default Model

¢ Open Button File: Opens a *.btn file previously saved

Hew Buttan Clrl+h
Open Button File Chel+0
Lloze

» Workspace items: Open, Close, and Save the entire Workspace operating
program for your MX-1000, including buttons and commands

¢ Import: Convert older MXOP files to the MX Designer format

Open Workspace
Cloze Workspace
Save Workspace

Save Az Workspace
Immport b e Using the Window menu, you can [ window
1 M Designer. ms Cascade or Tile all open Page displays. Cascade
2 b Designerz. mx M | | h h ” Tile
3 Dan buttonsmx oreover, you can also cycle through a SR
4 M Designer.ms open windows (unlike the arrow icons, =~ Ces=al
3 estareeno ms which cycle through a single device only). 1 MAIN
Exit 2AUDI0 - Page 1
3 Amow Right

A 40010 - Page 2

v BAUDIO - Page 4 k
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There are a few buttons that are unique to Designer.

DS EE e e T DA &

e The Upload and Download icons are self-explanatory.

e The Tree icon brings the Main Page back to the top of the pile when a number of windows are
open.

e The Left and Right arrow icons allow you to cycle through the open Pages of a single Device.

e There are two Text icons: the boxed LT edits text labels; the open T edlits text on the
background. You do not have to select these icons, usually: clicking on the area you want to edit
will activate the appropriate mode.

e The Text Size icons switch between small- and large-sized letters.

e The Grid icon overlays a positioning grid on Device Pages, to help you precisely locate any
buttons you choose to move.

e Cascade and Tile icons are a method of organizing Display Page windows.

e The Close icons allow you to close the currently-active window, or close all windows in the
Workspace at once.

WORKING WITH BUTTONS

Using MX Designer, you can add, delete, edit and create command buttons. You can also edit button
labels and add text directly to the background of any Page screen.

NOTE: All changes take place when you Exit the program and are asked to Save the

* mx file. _—
m‘ ?, g] Jimgm|
O O o
USING THE BUTTON TEMPLATES A
o v porom <]
Most button changes to Device Pages are saved automatically. The MX-1000 |.L 2 2 L
can hold about 50 button designs in active memory. If you create more buttons | ) & o E 7
than you can use, Designer allows you to store them for later retrieval on the | = @ £~
More buttons template. o - 5
Edit or create your buttons using the procedures described below. ) m
Save the button by clicking the Draw window close-button; the Icon
modified dialog box allows you to save directly to either the Buttons

VO
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or More buttons template, or as a * . btn file for future use or for
sharing.

NOTES: Only the buttons saved on the Button template tab are recognized by Designer
when downloading. Buttons stored in the More Buttons template are not used.

OPENING BUTTON FILES

You can open or save a button as an individual file by using the File > Open Button File menu item,
or by right clicking anywhere on one of the Button templates. If you click on a button located on one
of the button templates, you can also do a couple of other things, like Delete and Rename.

BUTTON PROPERTIES

By selecting the Properties item from the menu pop-out: Edit
. . Import button file [+ btn)
e you can rename the Icon Properties used to display button names Expor & button file [~ btn)
on the templates: Send ta 'Mare buttons'
¢ Icon name (visible name): This naming option is obvious. Delets

Fiename

o Default Button Name: The name you enter here automatically
becomes the button label next time you drag the button into
position on a Display Page.

To ADD A BUTTON TO A DEVICE

Open a page in the Device Tree. |f:r HDmEI = Bu[:]ﬂnns = — hums';I
Click the Button or More buttons tab.
Click and drag any button to the Device Page window.

PN

Click OK in the Button Function Property sheet that opens.

NOTE: Learned data commands are only available in the Button Function property
sheet if you have previously uploaded Learned Functions.

5. Drag the button into position. Changes are saved automatically. o

OPEN
/CLOSE

STILL sTILL
[ /STEP—]:[ ISTEP+] [PROGRA"

To DELETE A BUTTON

1. Select a button on any Device Page in the Page Preview windows.
2. Right-click and select Delete. Changes are saved automatically. @][ e )

Function prapetty

To EDIT A BUTTON —

Open a page in the Device Tree.
Click the Button or More buttons tab.

Double-click any button; a Button Draw window opens,
and the drawing tools display on the right side.

[ Unnamed.btn HE h

A

5 I . ]
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Drag the edge of the Button Draw window to provide a
floating workspace.

NOTE: Use the Window menu Cascade and Tile commands or buttons when working
with several Page preview windows to see all windows that have been opened.

5. Use any of the drawing tools, color selectors, and eraser to
alter your selected button.

When satisfied with the changes, click File > Save Button File, or File > Save Button As... .

Provide a name for the button; click OK.

L
To CREATE A NEW BUTTON 7 e
Click File > New Button File. I;I i
2. Use any of the drawing tools, color selectors, e
and two sizes of eraser to create a new button. L
3. When satisfied with the changes, click
File > Save Button File or Button Save As... . =%
4. Click one of the Save options:
¢ Yes, save as "More Buttons”: saves to the lcon modified gl
More but‘tOhS template Do you want to save the changes?
" " Select Name as
¢ Yes, save as "Buttons”: saves to the Buttons (A G e
' Yes, save as 'More B%ﬂuns' t ]
template <BW2>
£ Yes, save as 'Buttons’
e Yes, save as file (*.btn): saves as a button file, if £ Yes, save as file [.btn] [l’f"’"“ ":“"“ fame
. nname
you prefer to access it later © No |

5. Type an Icon name; this will identify the button in
the button template display.

6. Type a Default button
name; this provides a label
for the button when you
drag it onto a Device Page.

7. Click OK.

Cancel |

IMPORTING FILES FROM VERSION 1 OF MXOP

You can still use the command sets and program files you may have created in earlier versions of the
software. MX Designer is a completely revamped design tool for the MX-1000 remote. Version 1.x
files from the MX Operating Program are not compatible with MX Designer. They can, however, be
converted into Designer format. MXOP file types that can be converted are: MDL, PDT, BTN, and
LDT.

)
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To IMPORT MDL FiLEs FROM MXOP

1.

Click File > Import > MDL (button layout file).
2.

If you had previously imported any files, the program asks if you want to save your work.
Click YES and save the changes as a new .mx file.

NOTE: The saved .mx file is not compatible with the MXOP.

A Button.ini browser window opens; click the .ini file associated with the buttons in your
chosen .md1 file. A progress bar indicates success of the import procedure.

Make any button design or programming changes.

Exit the program, and save the new .mx file when prompted.
To IMPORT PDT FiLEs FROM MXOP

1. Click File > Import > PDT (preprogrammed Device command codes file).

2. If you had previously imported any files, the program asks if you want to save your work.
Click YES and save the changes as a new .mx file.

NOTE: The saved .mx file is not compatible with the MXOP.

3. Choose a PDT file in the file browser window and click Open.
4. Make any button design or programming changes.
5.

Exit the program, and save the new .mx file when prompted.

To IMPORT LDT FILES FROM MXOP

1.

Click File > Import > LDT (command codes you have taught to your remote).
2.

If you had previously imported any files, the program asks if you want to save your work.
Click YES and save the changes as a new .mx file.

NOTE: The saved .mx file is not compatible with the MXOP.

Choose an LDT file in the file browser window and click Open.
Make any button design or programming changes.

Exit the program, and save the new .mx file when prompted.
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